Export Problems in 10g OEM

by Andrew Albertson
by Andrew Albertson

I was working with one of our Oracle 10g databases the other day when I tried to do an data pump export using the OEM.
It seemed to be doing it, but then spat out this error:
ORA-20204: User does not exist:
EXP ORA-06512: at "SYSMAN.MGMT_USER", line 122
ORA-06512: at "SYSMAN.MGMT_JOBS", line 139
ORA-06512: at "SYSMAN.MGMT_JOBS", line 78
ORA-06512: at line 1

The error has something to do with the permissions for the user you are logged in as when doing the export.

To fix it you need to login to the Enterprise Manager Console and add the user who will run the Export/Import DataPump job as an Administrator who can login to Enterprise Manager.

  1. login as user SYSTEM or user SYS to the ‘Enterprise Manager 10g Database Control’
  2. At the top right, click on the link ‘Setup’
  3. On the page ‘Administrators’, click on the button ‘Create’
  4. On the page ‘Create Administrator: Properties’, add the user who will run the Export/Import DataPump job
  5. Click on the button: ‘Finish’
  6. On the page ‘Create Administrator: Review’, click on the button: ‘Finish’
  7. On the page ‘Administrators’, confirm that the user has been added.
  8. At the top right, click on the link ‘Logout’

Now login as the user who will run the Export/Import DataPump job and re-create the DataPump job.

via OTN Discussion Forums : Oracle Export Submit Fails : Export ….

One thought on “Export Problems in 10g OEM

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s